Raspbian Stretch te upgraden naar Raspbian Buster.

Raspbian Stretch te upgraden naar Raspbian Buster.

  • Laatste wijziging in bericht:06/08/2020
  • Berichtcategorie:Domoticz
  • Bericht reacties:6 Reacties
  • Leestijd:2 minuten gelezen
  • Bericht auteur:

De meest recente beta’s & stabiele versies van Domoticz werken alleen nog maar op Raspbian Buster. Mocht je nog Raspbian Stretch op je Raspberry Pi hebben staan en je installeert een nieuwe versie van Domoticz dan zal Domoticz niet meer starten.

Gelukkig is het vrij simpel van van Raspbian Stretch te upgraden naar Raspbian Buster.

Zorg dat alles up-to-date is:

Controleer dat je geen fouten hebt.
Voordat je verder gaat met upgraden:

Dit is erg aan te raden om te doen

Bereid de apt-get bronnen voor

Update de apt-get bronnen.
Met onderstaande commando’s vervang je “stretch” met “buster” in de repository-locaties:

Controleer met onderstaand commando of alle bronnen nu naar “buster” verwijzen:

Versnel de volgende stappen door de list changes package te verwijderen scheelt erg veel tijd (op het eind wel weer toevoegen!):

Upgrade naar Buster

Geef onderstaand commando in om alle packages te upgraden naar Buster, inclusief de kernel modules:

Verwijder de verouderde packages:

Controleer dat je nu Buster als os hebt:



Advertentie :


Update firmware

Een optionele stap is om de laste firmware te installeren:

Pas hier goed mee op je kunt hierdoor ook een niet meer werkend systeem krijgen, alleen raadzaam als ze dit vermelden bij een OS update of dat er via de officiële kanalen vanaf raspberry dit aangegeven word.

Tot slot installeer je de list changes package weer:

Herstart de Raspberry Pi met:

Je Raspberry Pi is nu weer helemaal up-to-date en je kunt de nieuwste stabiele versie van Domoticz v2020.2 installeren!
(14-05-2020 is dit de meest recente stabiele versie)

Voor een gehele nieuwe set-up of je wilt de stappen door lopen doe dan de onderstaande regel


Reclame – conrad.nl.



Spelfouten, taalfouten of inhoudelijke fouten ontdekt?
Stuur dan een mailtje naar de auteur van dit artikel!

Deel dit artikel !

0Shares
0 0
Abonneer
Abonneren op
guest

Deze website gebruikt Akismet om spam te verminderen. Bekijk hoe je reactie-gegevens worden verwerkt.

6 Reacties
Inline feedback
Bekijk alle reacties
Frits
Frits
Gast
14/05/2020 20:11

Als je eerst domoticz update en daarna buster er overheen zet zou domoticz dan weer werken.

Wobbe
Wobbe
Redacteur
Antwoord aan  Frits
14/05/2020 20:16

Hallo Frits,
Dat heb ik toen wel gedaan, omdat ik eerst niet had gelezen dat v2020.1 al Buster moest hebben.
En draait hier sinds dien hier nog perfect.

Ludo
Ludo
Gast
13/02/2021 21:41

Na het uitvoeren van deze update, had ik geen ZWave communicatie meer. Ook na diverse herstarts niet. Na het verplaatsen van de “AEON LABS Z-Stick Gen5 EU” naar een andere USB poort was dat probleem verholpen.

Ludo
Ludo
Gast
13/02/2021 21:46

Ander probleem waar ik tegenaan liep, was dat het ./updaterelease commando een “access denied” reactie opleverde. Het uitvoeren van de commando’s hieronder loste dat probleem weer op 🙂

sudo chmod +x updaterelease
sudo chmod +x domoticz.sh
en daarna:
./updaterelease
om de update naar de laatste domoticz versie uit te voeren